<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
	<meta name="google-site-verification" content="QcWbvI5aLyCORIhi8HdoLjd1yHgh0lUWL9zlB7kz4Hw" />
	<script data-ad-client="ca-pub-9982578686703193" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
	<script type="text/javascript">
 (function() {
 window.advBidxc = window.advBidxc || {};
 window.advBidxc.startTime = new Date().getTime();
 function loadScript(tagSrc) {
 var scriptTag = document.createElement('script'),
 placeTag = document.getElementsByTagName("script")[0];
 scriptTag.type = 'text/javascript';
 scriptTag.async = true;
 scriptTag.src = tagSrc;
 placeTag.parentNode.insertBefore(scriptTag, placeTag);
 }
 var mnSrc = '//hbx.media.net/bidexchange.js?cid=8CU2C156D&version=5.1' + '&dn=' +
window.location.hostname;
 loadScript(mnSrc);
 })();
</script>
    <title>Brixmor Property Group Inc. (BRX), Chiasma Inc. (CHMA): Another Look At Growth Versus Value | BOV News</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://bovnews.com/xmlrpc.php" />
    <meta property="og:image" content="https://bovnews.com/wp-content/uploads/2019/10/27.jpg" /><link rel="icon" type="image/png" href="http://bovnews.com/wp-content/uploads/2019/10/BOV-logo-new-300x35.png"><link rel="amphtml" href="https://bovnews.com/2020/10/07/brixmor-property-group-inc-brx-chiasma-inc-chma-another-look-at-growth-versus-value/amp/" /><meta name="generator" content="AMP for WP 1.0.62.2"/><link rel='dns-prefetch' href='//www.getpushmonkey.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="BOV News &raquo; Feed" href="https://bovnews.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="BOV News &raquo; Comments Feed" href="https://bovnews.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="BOV News &raquo; Brixmor Property Group Inc. (BRX), Chiasma Inc. (CHMA): Another Look At Growth Versus Value Comments Feed" href="https://bovnews.com/2020/10/07/brixmor-property-group-inc-brx-chiasma-inc-chma-another-look-at-growth-versus-value/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/bovnews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.4"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://bovnews.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.4' type='text/css' media='all' />
<link rel='stylesheet' id='ads-for-wp-front-css-css'  href='https://bovnews.com/wp-content/plugins/ads-for-wp/public/assets/css/adsforwp-front.min.css?ver=1.9.16.1' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-multi-purpose-css'  href='https://bovnews.com/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=9b761fb88cde3d1bd90677504fc739fc' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Roboto+Slab%3A400%7COpen+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900&#038;ver=9.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='https://bovnews.com/wp-content/themes/Newspaper/style.css?ver=9.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css'  href='https://bovnews.com/wp-content/themes/Newspaper/includes/demos/politics/demo_style.css?ver=9.2.2' type='text/css' media='all' />
<script type='text/javascript' src='https://bovnews.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://bovnews.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.getpushmonkey.com/sdk/config-TW6LON8QDVJHEBG1A.js?dialog_color=%23CEDE9B&#038;button_color=%2399CC56&#038;ver=5.3.4'></script>
<link rel='https://api.w.org/' href='https://bovnews.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://bovnews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://bovnews.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Positive Prospects, But Probably: Red Robin Gourmet Burgers Inc. (RRGB), Agenus Inc. (AGEN)' href='https://bovnews.com/2020/10/07/positive-prospects-but-probably-red-robin-gourmet-burgers-inc-rrgb-agenus-inc-agen/' />
<link rel='next' title='EPS Surprise As An Investment Strategy: Hostess Brands Inc. (TWNK), Amneal Pharmaceuticals Inc. (AMRX)' href='https://bovnews.com/2020/10/07/eps-surprise-as-an-investment-strategy-hostess-brands-inc-twnk-amneal-pharmaceuticals-inc-amrx/' />
<meta name="generator" content="WordPress 5.3.4" />
<link rel="canonical" href="https://bovnews.com/2020/10/07/brixmor-property-group-inc-brx-chiasma-inc-chma-another-look-at-growth-versus-value/" />
<link rel='shortlink' href='https://bovnews.com/?p=189342' />
<link rel="alternate" type="application/json+oembed" href="https://bovnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbovnews.com%2F2020%2F10%2F07%2Fbrixmor-property-group-inc-brx-chiasma-inc-chma-another-look-at-growth-versus-value%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://bovnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbovnews.com%2F2020%2F10%2F07%2Fbrixmor-property-group-inc-brx-chiasma-inc-chma-another-look-at-growth-versus-value%2F&#038;format=xml" />
        <script type="text/javascript">              
              jQuery(document).ready( function($) {    
                  if ($('#adsforwp-hidden-block').length == 0 ) {
                       $.getScript("https://bovnews.com/front.js");
                  }
              });
         </script>
       			<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/bovnews.com\/wp-admin\/","wpRestNonce":"22be285dab","wpRestUrl":"https:\/\/bovnews.com\/wp-json\/","permalinkStructure":"\/%year%\/%monthnum%\/%day%\/%postname%\/"};
			</script>
			<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
    
<!-- JS generated by theme -->

<script>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</script>


<!-- Header style compiled by theme -->

<style>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</style>

<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-142299389-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-142299389-1');
</script>


<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://bovnews.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://bovnews.com/category/finance/",
                    "name": "Finance"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://bovnews.com/2020/10/07/brixmor-property-group-inc-brx-chiasma-inc-chma-another-look-at-growth-versus-value/",
                    "name": "Brixmor Property Group Inc. (BRX), Chiasma Inc. (CHMA): Another Look At Growth..."                                
                }
            }    
        ]
    }
</script>
<link rel="icon" href="https://bovnews.com/wp-content/uploads/2019/10/cropped-BOV-logo-new-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://bovnews.com/wp-content/uploads/2019/10/cropped-BOV-logo-new-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://bovnews.com/wp-content/uploads/2019/10/cropped-BOV-logo-new-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://bovnews.com/wp-content/uploads/2019/10/cropped-BOV-logo-new-1-270x270.png" />

<!-- Button style compiled by theme -->

<style>
    .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .current-category-ancestor > a,
                .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .current-menu-ancestor > a,
                .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .current-menu-item > a,
                .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .sfHover > a,
                .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > li > a:hover,
                .tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,
                .tds-button2 .tdm-btn-text,
                .tds-button2 i,
                .tds-button5:hover .tdm-btn-text,
                .tds-button5:hover i,
                .tds-button6 .tdm-btn-text,
                .tds-button6 i,
                .tdm_block_list .tdm-list-item i,
                .tdm_block_pricing .tdm-pricing-feature i,
                .tdm-social-item i {
                  color: #3949ab;
                }
                .tdm-menu-active-style5 .td-header-menu-wrap .sf-menu > .current-menu-item > a,
                .tdm-menu-active-style5 .td-header-menu-wrap .sf-menu > .current-menu-ancestor > a,
                .tdm-menu-active-style5 .td-header-menu-wrap .sf-menu > .current-category-ancestor > a,
                .tdm-menu-active-style5 .td-header-menu-wrap .sf-menu > li > a:hover,
                .tdm-menu-active-style5 .td-header-menu-wrap .sf-menu > .sfHover > a,
                .tds-button1,
                .tds-button6:after,
                .tds-title2 .tdm-title-line:after,
                .tds-title3 .tdm-title-line:after,
                .tdm_block_pricing.tdm-pricing-featured:before,
                .tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,
                .tds-progress-bar1 .tdm-progress-bar:after,
                .tds-progress-bar2 .tdm-progress-bar:after,
                .tds-social3 .tdm-social-item {
                  background-color: #3949ab;
                }
                .tdm-menu-active-style4 .tdm-header .sf-menu > .current-menu-item > a,
                .tdm-menu-active-style4 .tdm-header .sf-menu > .current-menu-ancestor > a,
                .tdm-menu-active-style4 .tdm-header .sf-menu > .current-category-ancestor > a,
                .tdm-menu-active-style4 .tdm-header .sf-menu > li > a:hover,
                .tdm-menu-active-style4 .tdm-header .sf-menu > .sfHover > a,
                .tds-button2:before,
                .tds-button6:before,
                .tds-progress-bar3 .tdm-progress-bar:after {
                  border-color: #3949ab;
                }
                .tdm-btn-style1 {
					background-color: #3949ab;
				}
				.tdm-btn-style2:before {
				    border-color: #3949ab;
				}
				.tdm-btn-style2 {
				    color: #3949ab;
				}
				.tdm-btn-style3 {
				    -webkit-box-shadow: 0 2px 16px #3949ab;
                    -moz-box-shadow: 0 2px 16px #3949ab;
                    box-shadow: 0 2px 16px #3949ab;
				}
				.tdm-btn-style3:hover {
				    -webkit-box-shadow: 0 4px 26px #3949ab;
                    -moz-box-shadow: 0 4px 26px #3949ab;
                    box-shadow: 0 4px 26px #3949ab;
				}
				
				
                .tdm-header-style-1.td-header-wrap .td-header-top-menu-full,
                .tdm-header-style-1.td-header-wrap .top-header-menu .sub-menu,
                .tdm-header-style-2.td-header-wrap .td-header-top-menu-full,
                .tdm-header-style-2.td-header-wrap .top-header-menu .sub-menu,
                .tdm-header-style-3.td-header-wrap .td-header-top-menu-full,
                .tdm-header-style-3.td-header-wrap .top-header-menu .sub-menu{
                    background-color: #000000;
                }
</style>

	<style id="tdw-css-placeholder"></style>	<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-142299389-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-142299389-1');
</script>
</head>

<body class="post-template-default single single-post postid-189342 single-format-standard global-block-template-1 td-politics single_template_5 td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="#" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="#" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="#" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="#" title="Vimeo">
                <i class="td-icon-font td-icon-vimeo"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="#" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
                    <div class="td-menu-login-section">
                
    <div class="td-guest-wrap">
        <div class="td-menu-avatar"><div class="td-avatar-container"><img alt='' src='https://secure.gravatar.com/avatar/?s=80&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=160&#038;d=mm&#038;r=g 2x' class='avatar avatar-80 photo avatar-default' height='80' width='80' /></div></div>
        <div class="td-menu-login"><a id="login-link-mob">Sign in</a></div>
    </div>
            </div>
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-td-demo-header-menu-container"><ul id="menu-td-demo-header-menu" class="td-mobile-main-menu"><li id="menu-item-47" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first menu-item-47"><a href="https://bovnews.com/">Home</a></li>
<li id="menu-item-120" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-120"><a href="https://bovnews.com/category/market/">Market</a></li>
<li id="menu-item-121" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-121"><a href="https://bovnews.com/category/companies/">Companies</a></li>
<li id="menu-item-122" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-122"><a href="https://bovnews.com/category/finance/">Finance</a></li>
<li id="menu-item-123" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-123"><a href="https://bovnews.com/category/industry/">Industry</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
            <div id="login-form-mobile" class="td-register-section">
            
            <div id="td-login-mob" class="td-login-animation td-login-hide-mob">
            	<!-- close button -->
	            <div class="td-login-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Sign in</div>
	                <!-- close button -->
		            <div class="td-mobile-close">
		                <a href="#"><i class="td-icon-close-mobile"></i></a>
		            </div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
	                <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
	                <div class="td-login-info-text">
	                <a href="#" id="forgot-pass-link-mob">Forgot your password?</a>
	                </div>
	                
	                
	                
                </div>
            </div>

            
            
            
            
            <div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">
                <!-- close button -->
	            <div class="td-forgot-pass-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Password recovery</div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title">Recover your password</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
	                <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
                </div>
            </div>
        </div>
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="https://bovnews.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>    
    
    <div id="td-outer-wrap" class="td-theme-wrap">
    
        <!--
Header style 11
-->

<div class="td-header-wrap td-header-style-11 ">
    
	<div class="td-header-top-menu-full td-container-wrap ">
		<div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	        <div class="td_data_time">
            <div >

                Wednesday, October 7, 2020
            </div>
        </div>
    <ul class="top-header-menu td_ul_login"><li class="menu-item"><a class="td-login-modal-js menu-item" href="#login-form" data-effect="mpf-td-login-effect">Sign in / Join</a><span class="td-sp-ico-login td_sp_login_ico_style"></span></li></ul><div class="menu-top-container"><ul id="menu-td-demo-top-menu" class="top-header-menu"><li id="menu-item-124" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-124"><a href="https://bovnews.com/">Home</a></li>
<li id="menu-item-125" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-125"><a href="https://bovnews.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-126" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-126"><a href="https://bovnews.com/our-team/">Our Team</a></li>
<li id="menu-item-127" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-127"><a href="https://bovnews.com/our-company/">Our Company</a></li>
<li id="menu-item-128" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-128"><a href="https://bovnews.com/disclaimer/">Disclaimer</a></li>
<li id="menu-item-129" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-129"><a href="https://bovnews.com/contacts/">Contacts</a></li>
</ul></div></div>
        <div class="td-header-sp-top-widget">
    
    </div>    </div>

<!-- LOGIN MODAL -->

                <div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
                    <div class="td-login-wrap">
                        <a href="#" class="td-back-button"><i class="td-icon-modal-back"></i></a>
                        <div id="td-login-div" class="td-login-form-div td-display-block">
                            <div class="td-login-panel-title">Sign in</div>
                            <div class="td-login-panel-descr">Welcome! Log into your account</div>
                            <div class="td_display_err"></div>
                            <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email" value="" required><label>your username</label></div>
	                        <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" required><label>your password</label></div>
                            <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login">
                            <div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div>
                            
                            
                            
                            
                        </div>

                        

                         <div id="td-forgot-pass-div" class="td-login-form-div td-display-none">
                            <div class="td-login-panel-title">Password recovery</div>
                            <div class="td-login-panel-descr">Recover your password</div>
                            <div class="td_display_err"></div>
                            <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label>your email</label></div>
                            <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password">
                            <div class="td-login-info-text">A password will be e-mailed to you.</div>
                        </div>
                        
                        
                    </div>
                </div>
                		</div>
	</div>

    <div class="td-header-menu-wrap-full td-container-wrap ">
        
        <div class="td-header-menu-wrap td-header-gradient ">
            <div class="td-container td-header-row td-header-main-menu">
                <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-header">
        		<a class="td-mobile-logo td-sticky-disable" href="https://bovnews.com/">
			<img src="http://bovnews.com/wp-content/uploads/2019/10/BOV-logo-new-300x35.png" alt=""/>
		</a>
			<a class="td-header-logo td-sticky-disable" href="https://bovnews.com/">
			<img src="http://bovnews.com/wp-content/uploads/2019/10/BOV-logo-new-300x35.png" alt=""/>
		</a>
	    </div>
    <div class="menu-td-demo-header-menu-container"><ul id="menu-td-demo-header-menu-1" class="sf-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-47"><a href="https://bovnews.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-120"><a href="https://bovnews.com/category/market/">Market</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-121"><a href="https://bovnews.com/category/companies/">Companies</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-122"><a href="https://bovnews.com/category/finance/">Finance</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-123"><a href="https://bovnews.com/category/industry/">Industry</a></li>
</ul></div></div>


    <div class="header-search-wrap">
        <div class="td-search-btns-wrap">
            <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
        </div>

        <div class="td-drop-down-search" aria-labelledby="td-header-search-button">
            <form method="get" class="td-search-form" action="https://bovnews.com/">
                <div role="search" class="td-head-form-search-wrap">
                    <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
                </div>
            </form>
            <div id="td-aj-search"></div>
        </div>
    </div>
            </div>
        </div>
    </div>

    <div class="td-banner-wrap-full td-logo-wrap-full td-logo-mobile-loaded td-container-wrap ">
        <div class="td-header-sp-logo">
            			<a class="td-main-logo" href="https://bovnews.com/">
				<img src="http://bovnews.com/wp-content/uploads/2019/10/BOV-logo-new-300x35.png" alt=""/>
				<span class="td-visual-hidden">BOV News</span>
			</a>
		        </div>
    </div>

            <div class="td-banner-wrap-full td-banner-bg td-container-wrap ">
            <div class="td-container-header td-header-row td-header-header">
                <div class="td-header-sp-recs">
                    <div class="td-header-rec-wrap">
    
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-header td_uid_1_5f7e06dc135e2_rand td_block_template_1 ">
<script type="text/javascript">
var td_screen_width = window.innerWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-9982578686703193" data-ad-slot="2447106658"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-9982578686703193" data-ad-slot="2447106658"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-9982578686703193" data-ad-slot="2447106658"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:320px;height:50px" data-ad-client="ca-pub-9982578686703193" data-ad-slot="2447106658"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 


</div>                </div>
            </div>
        </div>
    
</div><div class="td-main-content-wrap td-container-wrap">

    <div class="td-container td-post-template-5 ">
        <div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://bovnews.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Finance" class="entry-crumb" href="https://bovnews.com/category/finance/">Finance</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Brixmor Property Group Inc. (BRX), Chiasma Inc. (CHMA): Another Look At Growth...</span></div></div>
            <div class="td-pb-row">
                                            <div class="td-pb-span8 td-main-content" role="main">
                                <div class="td-ss-main-content">
                                    
    <article id="post-189342" class="post-189342 post type-post status-publish format-standard has-post-thumbnail hentry category-finance tag-brixmor-property-group-inc tag-brx tag-brx-stock tag-chiasma-inc tag-chma tag-chma-stock tag-nasdaqchma tag-nysebrx" itemscope itemtype="https://schema.org/Article">
        <div class="td-post-header">
            <ul class="td-category"><li class="entry-category"><a  href="https://bovnews.com/category/finance/">Finance</a></li></ul>
            <header class="td-post-title">
                <h1 class="entry-title">Brixmor Property Group Inc. (BRX), Chiasma Inc. (CHMA): Another Look At Growth Versus Value</h1>

                

                <div class="td-module-meta-info">
                    <div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://bovnews.com/author/peggy-goldman/">Peggy Goldman</a><div class="td-author-line"> - </div> </div>                    <span class="td-post-date td-post-date-no-dot"><time class="entry-date updated td-module-date" datetime="2020-10-07T17:09:00+00:00" >October 7, 2020</time></span>                                                        </div>

            </header>

        </div>

        <div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fbovnews.com%2F2020%2F10%2F07%2Fbrixmor-property-group-inc-brx-chiasma-inc-chma-another-look-at-growth-versus-value%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Brixmor+Property+Group+Inc.+%28BRX%29%2C+Chiasma+Inc.+%28CHMA%29%3A+Another+Look+At+Growth+Versus+Value&url=https%3A%2F%2Fbovnews.com%2F2020%2F10%2F07%2Fbrixmor-property-group-inc-brx-chiasma-inc-chma-another-look-at-growth-versus-value%2F&via=BOV+News">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-googleplus" href="https://plus.google.com/share?url=https://bovnews.com/2020/10/07/brixmor-property-group-inc-brx-chiasma-inc-chma-another-look-at-growth-versus-value/">
                                        <div class="td-social-but-icon"><i class="td-icon-googleplus"></i></div>
                                        <div class="td-social-but-text">Google+</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://bovnews.com/2020/10/07/brixmor-property-group-inc-brx-chiasma-inc-chma-another-look-at-growth-versus-value/&amp;media=https://bovnews.com/wp-content/uploads/2019/10/27.jpg&description=Brixmor+Property+Group+Inc.+%28BRX%29%2C+Chiasma+Inc.+%28CHMA%29%3A+Another+Look+At+Growth+Versus+Value">
                                        <div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
                                        <div class="td-social-but-text">Pinterest</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Brixmor Property Group Inc. (BRX), Chiasma Inc. (CHMA): Another Look At Growth Versus Value %0A%0A https://bovnews.com/2020/10/07/brixmor-property-group-inc-brx-chiasma-inc-chma-another-look-at-growth-versus-value/">
                                        <div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
                                        <div class="td-social-but-text">WhatsApp</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>

        <div class="td-post-content">
            
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-content_top td_uid_2_5f7e06dc19b4c_rand td_block_template_1 ">
<script type="text/javascript">
var td_screen_width = window.innerWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-9982578686703193" data-ad-slot="8608070767"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-9982578686703193" data-ad-slot="8608070767"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-9982578686703193" data-ad-slot="8608070767"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-9982578686703193" data-ad-slot="8608070767"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 

<p>NORTHERN TRUST GLOBAL INVESTMENT bought a fresh place in Brixmor Property Group Inc. (NYSE:BRX). The institutional investor bought 7.2 thousand shares of the stock in a transaction took place on 8/31/2020. In another most recent transaction, which held on 9/03/2020, STATE STREET GLOBAL ADVISORS LTD bought approximately 502.00 shares of Brixmor Property Group Inc. In a separate transaction which took place on 9/03/2020, the institutional investor, VANECK VECTORS AUSTRALIA PTY LTD bought 39.00 shares of the company’s stock. </p>
<p>In the most recent purchasing and selling session, Brixmor Property Group Inc. (BRX)’s share price increased by 0.80 percent to ratify at $12.60. A sum of 3063373 shares traded at recent session and its average exchanging volume remained at 2.62M shares. The 52-week price high and low points are important variables to concentrate on when assessing the current and prospective worth of a stock. Brixmor Property Group Inc. (BRX) shares are taking a pay cut of -44.59% from the high point of 52 weeks and flying high of 67.78% from the low figure of 52 weeks.</p><div data-ad-id="46564" style="text-align:center; margin-top:px; margin-bottom:px; margin-left:px; margin-right:px;float:none;" class="afw afw-ga afw_ad afwadid-46564  ">
                                                                
                                              <script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js">
                                              </script>
                                      <ins 
                                      class="adsbygoogle" 
                                      style="background:none;display:inline-block;max-width:800px;width:100%;height:120px;max-height:120px;"                 
                                      data-ad-client="ca-pub-9982578686703193"
                                      data-ad-slot="2162081913"
                                      data-ad-format="auto"
                                      data-full-width-responsive="true">
                                      </ins>
                                              <script>
                                                      (adsbygoogle = window.adsbygoogle || []).push({});
                                              </script>
                                              
                                      </div>
<p>Brixmor Property Group Inc. (BRX) shares reached a high of $12.98 and dropped to a low of $12.42 until finishing in the latest session at $12.65. Traders and investors may also choose to study the ATR or Average True Range when concentrating on technical inventory assessment. Currently at 0.56 is the 14-day ATR for Brixmor Property Group Inc. (BRX). The highest level of 52-weeks price has $22.74 and $7.51 for 52 weeks lowest level. After the recent changes in the price, the firm captured the enterprise value of $8.27B, with the price to earnings ratio of 17.72. </p>
<p>Having a look at past record, we&#8217;re going to look at various forwards or backwards shifting developments regarding BRX. The firm&#8217;s shares rose 8.06 percent in the past five business days and shrunk -3.37 percent in the past thirty business days. In the previous quarter, the stock rose 2.86 percent at some point. The output of the stock increased 29.36 percent within the six-month closing period, while general annual output lost -38.08 percent. The company&#8217;s performance is now negative at -41.69% from the beginning of the calendar year. </p><div data-ad-id="46564" style="text-align:center; margin-top:px; margin-bottom:px; margin-left:px; margin-right:px;float:none;" class="afw afw-ga afw_ad afwadid-46564  ">
                                                                
                                              <script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js">
                                              </script>
                                      <ins 
                                      class="adsbygoogle" 
                                      style="background:none;display:inline-block;max-width:800px;width:100%;height:120px;max-height:120px;"                 
                                      data-ad-client="ca-pub-9982578686703193"
                                      data-ad-slot="2162081913"
                                      data-ad-format="auto"
                                      data-full-width-responsive="true">
                                      </ins>
                                              <script>
                                                      (adsbygoogle = window.adsbygoogle || []).push({});
                                              </script>
                                              
                                      </div>
<p>According to WSJ, Brixmor Property Group Inc. (BRX) obtained an estimated Hold proposal from the 13 brokerage firms currently keeping a deep eye on the stock performance as compares to its rivals. 1 equity research analysts rated the shares with a selling strategy, 8 gave a hold approach, 4 gave a purchase tip, 0 gave the firm a overweight advice and 0 put the stock under the underweight category. The average price goal of one year between several banks and credit unions that last year discussed the stock is $13.75. </p>
<p>Chiasma Inc. (CHMA) shares on Tuesday&#8217;s trading session, dropped 0.00 percent to see the stock exchange hands at $4.14 per unit. Lets a quick look at company’s past reported and future predictions of growth using the EPS Growth. EPS growth is a percentage change in standardized earnings per share over the trailing-twelve-month period to the current year-end. The company posted a value of -$1.35 as earning-per-share over the last full year, while a chance, will post -$1.03 for the coming year. The current EPS Growth rate for the company during the year is 17.10% and predicted to reach at 38.00% for the coming year. In-depth, if we analyze for the long-term EPS Growth, the out-come was -51.60% for the past five years and the scenario is totally different as the current prediction is 46.30% for the next five year. </p><div data-ad-id="46564" style="text-align:center; margin-top:px; margin-bottom:px; margin-left:px; margin-right:px;float:none;" class="afw afw-ga afw_ad afwadid-46564  ">
                                                                
                                              <script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js">
                                              </script>
                                      <ins 
                                      class="adsbygoogle" 
                                      style="background:none;display:inline-block;max-width:800px;width:100%;height:120px;max-height:120px;"                 
                                      data-ad-client="ca-pub-9982578686703193"
                                      data-ad-slot="2162081913"
                                      data-ad-format="auto"
                                      data-full-width-responsive="true">
                                      </ins>
                                              <script>
                                                      (adsbygoogle = window.adsbygoogle || []).push({});
                                              </script>
                                              
                                      </div>
<p>The last trading period has seen Chiasma Inc. (CHMA) move -46.58% and 43.75% from the stock&#8217;s 52-week high and 52-week low prices respectively. The daily trading volume for Chiasma Inc. (NASDAQ:CHMA) over the last session is 1.14 million shares. CHMA has attracted considerable attention from traders and investors, a scenario that has seen its volume jump 101.43% compared to the previous one. </p>
<p>Investors focus on the profitability proportions of the company that how the company performs at profitability side. Return on equity ratio or ROE is a significant indicator for prospective investors as they would like to see just how effectively a business is using their cash to produce net earnings. As a return on equity, Chiasma Inc. (NASDAQ:CHMA) produces -73.50%. Because it would be easy and highly flexible, ROI measurement is among the most popular investment ratios. Executives could use it to evaluate the levels of performance on acquisitions of capital equipment whereas investors can determine that how the stock investment is better. The ROI entry for CHMA&#8217;s scenario is at 0.00%. Another main metric of a profitability ratio is the return on assets ratio or ROA that analyses how effectively a business can handle its assets to generate earnings over a duration of time. Chiasma Inc. (CHMA) generated -58.20% ROA for the trading twelve-month. </p><div data-ad-id="46564" style="text-align:center; margin-top:px; margin-bottom:px; margin-left:px; margin-right:px;float:none;" class="afw afw-ga afw_ad afwadid-46564  ">
                                                                
                                              <script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js">
                                              </script>
                                      <ins 
                                      class="adsbygoogle" 
                                      style="background:none;display:inline-block;max-width:800px;width:100%;height:120px;max-height:120px;"                 
                                      data-ad-client="ca-pub-9982578686703193"
                                      data-ad-slot="2162081913"
                                      data-ad-format="auto"
                                      data-full-width-responsive="true">
                                      </ins>
                                              <script>
                                                      (adsbygoogle = window.adsbygoogle || []).push({});
                                              </script>
                                              
                                      </div>
<p>Volatility is just a proportion of the anticipated day by day value extend—the range where an informal investor works. Greater instability implies more noteworthy benefit or misfortune. After an ongoing check, Chiasma Inc. (CHMA) stock is found to be 4.87% volatile for the week, while 5.64% volatility is recorded for the month. The outstanding shares have been calculated 57.80M. Based on a recent bid, its distance from 20 days simple moving average is -14.83%, and its distance from 50 days simple moving average is -14.36% while it has a distance of -15.81% from the 200 days simple moving average. </p>
<p>The Williams Percent Range or Williams %R is a well-known specialized pointer made by Larry Williams to help recognize overbought and oversold circumstances. Chiasma Inc. (NASDAQ:CHMA)’s Williams Percent Range or Williams %R at the time of writing to be seated at 75.93% for 9-Day. It is also calculated for different time spans. Currently for this organization, Williams %R is stood at 91.98% for 14-Day, 92.49% for 20-Day, 92.49% for 50-Day and to be seated 86.36% for 100-Day. Relative Strength Index, or RSI(14), which is a technical analysis gauge, also used to measure momentum on a scale of zero to 100 for overbought and oversold. In the case of Chiasma Inc., the RSI reading has hit 30.43 for 14-Day.</p><div data-ad-id="46564" style="text-align:center; margin-top:px; margin-bottom:px; margin-left:px; margin-right:px;float:none;" class="afw afw-ga afw_ad afwadid-46564  ">
                                                                
                                              <script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js">
                                              </script>
                                      <ins 
                                      class="adsbygoogle" 
                                      style="background:none;display:inline-block;max-width:800px;width:100%;height:120px;max-height:120px;"                 
                                      data-ad-client="ca-pub-9982578686703193"
                                      data-ad-slot="2162081913"
                                      data-ad-format="auto"
                                      data-full-width-responsive="true">
                                      </ins>
                                              <script>
                                                      (adsbygoogle = window.adsbygoogle || []).push({});
                                              </script>
                                              
                                      </div>
<div class="td-a-rec td-a-rec-id-content_bottom  td_uid_3_5f7e06dc19d7d_rand td_block_template_1"><div id="bovnews_ros_belowpost_1"></div>
</div>        </div>


        <footer>
                        
            <div class="td-post-source-tags">
                                <ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://bovnews.com/tag/brixmor-property-group-inc/">Brixmor Property Group Inc.</a></li><li><a href="https://bovnews.com/tag/brx/">BRX</a></li><li><a href="https://bovnews.com/tag/brx-stock/">BRX stock</a></li><li><a href="https://bovnews.com/tag/chiasma-inc/">Chiasma Inc.</a></li><li><a href="https://bovnews.com/tag/chma/">CHMA</a></li><li><a href="https://bovnews.com/tag/chma-stock/">CHMA stock</a></li><li><a href="https://bovnews.com/tag/nasdaqchma/">NASDAQ:CHMA</a></li><li><a href="https://bovnews.com/tag/nysebrx/">NYSE:BRX</a></li></ul>            </div>

            <div class="td-post-sharing-bottom"><div class="td-post-sharing-classic"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://bovnews.com/2020/10/07/brixmor-property-group-inc-brx-chiasma-inc-chma-another-look-at-growth-versus-value/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></div><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fbovnews.com%2F2020%2F10%2F07%2Fbrixmor-property-group-inc-brx-chiasma-inc-chma-another-look-at-growth-versus-value%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Brixmor+Property+Group+Inc.+%28BRX%29%2C+Chiasma+Inc.+%28CHMA%29%3A+Another+Look+At+Growth+Versus+Value&url=https%3A%2F%2Fbovnews.com%2F2020%2F10%2F07%2Fbrixmor-property-group-inc-brx-chiasma-inc-chma-another-look-at-growth-versus-value%2F&via=BOV+News">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-googleplus" href="https://plus.google.com/share?url=https://bovnews.com/2020/10/07/brixmor-property-group-inc-brx-chiasma-inc-chma-another-look-at-growth-versus-value/">
                                        <div class="td-social-but-icon"><i class="td-icon-googleplus"></i></div>
                                        <div class="td-social-but-text">Google+</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://bovnews.com/2020/10/07/brixmor-property-group-inc-brx-chiasma-inc-chma-another-look-at-growth-versus-value/&amp;media=https://bovnews.com/wp-content/uploads/2019/10/27.jpg&description=Brixmor+Property+Group+Inc.+%28BRX%29%2C+Chiasma+Inc.+%28CHMA%29%3A+Another+Look+At+Growth+Versus+Value">
                                        <div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
                                        <div class="td-social-but-text">Pinterest</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Brixmor Property Group Inc. (BRX), Chiasma Inc. (CHMA): Another Look At Growth Versus Value %0A%0A https://bovnews.com/2020/10/07/brixmor-property-group-inc-brx-chiasma-inc-chma-another-look-at-growth-versus-value/">
                                        <div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
                                        <div class="td-social-but-text">WhatsApp</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>			<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block"
     data-ad-format="autorelaxed"
     data-ad-client="ca-pub-9982578686703193"
     data-ad-slot="5246310836"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
            <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://bovnews.com/2020/10/07/positive-prospects-but-probably-red-robin-gourmet-burgers-inc-rrgb-agenus-inc-agen/">Positive Prospects, But Probably: Red Robin Gourmet Burgers Inc. (RRGB), Agenus Inc. (AGEN)</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="https://bovnews.com/2020/10/07/eps-surprise-as-an-investment-strategy-hostess-brands-inc-twnk-amneal-pharmaceuticals-inc-amrx/">EPS Surprise As An Investment Strategy: Hostess Brands Inc. (TWNK), Amneal Pharmaceuticals Inc. (AMRX)</a></div></div></div>            <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://bovnews.com/author/peggy-goldman/">Peggy Goldman</a></span></div>            <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Peggy Goldman"></span><meta itemprop="datePublished" content="2020-10-07T17:09:00+00:00"><meta itemprop="dateModified" content="2020-10-07T17:09:00+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://bovnews.com/2020/10/07/brixmor-property-group-inc-brx-chiasma-inc-chma-another-look-at-growth-versus-value/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://bovnews.com/wp-content/uploads/2019/10/BOV-logo-new-300x35.png"></span><meta itemprop="name" content="BOV News"></span><meta itemprop="headline " content="Brixmor Property Group Inc. (BRX), Chiasma Inc. (CHMA): Another Look At Growth Versus Value"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://bovnews.com/wp-content/uploads/2019/10/27.jpg"><meta itemprop="width" content="700"><meta itemprop="height" content="420"></span>        </footer>

    </article> <!-- /.post -->

    <div class="td_block_wrap td_block_related_posts td_uid_4_5f7e06dc1a669_rand td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_4_5f7e06dc1a669" ><script>var block_td_uid_4_5f7e06dc1a669 = new tdBlock();
block_td_uid_4_5f7e06dc1a669.id = "td_uid_4_5f7e06dc1a669";
block_td_uid_4_5f7e06dc1a669.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"td_uid_4_5f7e06dc1a669_rand","td_column_number":3,"live_filter_cur_post_id":189342,"live_filter_cur_post_author":"5","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"td_uid_4_5f7e06dc1a669_rand","tdc_css_class_style":"td_uid_4_5f7e06dc1a669_rand_style"}';
block_td_uid_4_5f7e06dc1a669.td_column_number = "3";
block_td_uid_4_5f7e06dc1a669.block_type = "td_block_related_posts";
block_td_uid_4_5f7e06dc1a669.post_count = "3";
block_td_uid_4_5f7e06dc1a669.found_posts = "2872";
block_td_uid_4_5f7e06dc1a669.header_color = "";
block_td_uid_4_5f7e06dc1a669.ajax_pagination_infinite_stop = "";
block_td_uid_4_5f7e06dc1a669.max_num_pages = "958";
tdBlocksArray.push(block_td_uid_4_5f7e06dc1a669);
</script><h4 class="td-related-title td-block-title"><a id="td_uid_5_5f7e06dc221c8" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_4_5f7e06dc1a669" href="#">RELATED ARTICLES</a><a id="td_uid_6_5f7e06dc221ce" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_4_5f7e06dc1a669" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_4_5f7e06dc1a669 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://bovnews.com/2020/10/07/may-prove-more-resilient-than-the-market-believes-boston-properties-inc-bxp-and-the-cheesecake-factory-incorporated-cake/" rel="bookmark" class="td-image-wrap" title="May Prove More Resilient Than The Market Believes: Boston Properties Inc. (BXP) and The Cheesecake Factory Incorporated (CAKE)"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="May Prove More Resilient Than The Market Believes: Boston Properties Inc. (BXP) and The Cheesecake Factory Incorporated (CAKE)" data-type="image_tag" data-img-url="https://bovnews.com/wp-content/uploads/2019/10/7-218x150.jpeg"  width="218" height="150" /></a></div>                <a href="https://bovnews.com/category/finance/" class="td-post-category">Finance</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://bovnews.com/2020/10/07/may-prove-more-resilient-than-the-market-believes-boston-properties-inc-bxp-and-the-cheesecake-factory-incorporated-cake/" rel="bookmark" title="May Prove More Resilient Than The Market Believes: Boston Properties Inc. (BXP) and The Cheesecake Factory Incorporated (CAKE)">May Prove More Resilient Than The Market Believes: Boston Properties Inc. (BXP) and The Cheesecake Factory Incorporated (CAKE)</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://bovnews.com/2020/10/07/time-to-buy-the-turnaround-biontech-se-bntx-and-american-homes-4-rent-amh/" rel="bookmark" class="td-image-wrap" title="Time To Buy The Turnaround: BioNTech SE (BNTX) and American Homes 4 Rent (AMH)"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="Time To Buy The Turnaround: BioNTech SE (BNTX) and American Homes 4 Rent (AMH)" data-type="image_tag" data-img-url="https://bovnews.com/wp-content/uploads/2019/10/30-218x150.jpg"  width="218" height="150" /></a></div>                <a href="https://bovnews.com/category/finance/" class="td-post-category">Finance</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://bovnews.com/2020/10/07/time-to-buy-the-turnaround-biontech-se-bntx-and-american-homes-4-rent-amh/" rel="bookmark" title="Time To Buy The Turnaround: BioNTech SE (BNTX) and American Homes 4 Rent (AMH)">Time To Buy The Turnaround: BioNTech SE (BNTX) and American Homes 4 Rent (AMH)</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://bovnews.com/2020/10/07/market-maelstrom-means-great-entry-point-in-twist-bioscience-corporation-twst-and-invitation-homes-inc-invh/" rel="bookmark" class="td-image-wrap" title="Market Maelstrom Means Great Entry Point in Twist Bioscience Corporation (TWST) and Invitation Homes Inc. (INVH)"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="Market Maelstrom Means Great Entry Point in Twist Bioscience Corporation (TWST) and Invitation Homes Inc. (INVH)" data-type="image_tag" data-img-url="https://bovnews.com/wp-content/uploads/2019/10/3-1-218x150.jpg"  width="218" height="150" /></a></div>                <a href="https://bovnews.com/category/finance/" class="td-post-category">Finance</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://bovnews.com/2020/10/07/market-maelstrom-means-great-entry-point-in-twist-bioscience-corporation-twst-and-invitation-homes-inc-invh/" rel="bookmark" title="Market Maelstrom Means Great Entry Point in Twist Bioscience Corporation (TWST) and Invitation Homes Inc. (INVH)">Market Maelstrom Means Great Entry Point in Twist Bioscience Corporation (TWST) and Invitation Homes Inc. (INVH)</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_4_5f7e06dc1a669" data-td_block_id="td_uid_4_5f7e06dc1a669"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_4_5f7e06dc1a669" data-td_block_id="td_uid_4_5f7e06dc1a669"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->
                                </div>
                            </div>
                            <div class="td-pb-span4 td-main-sidebar" role="complementary">
                                <div class="td-ss-main-sidebar">
                                    
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-sidebar td_uid_7_5f7e06dc24494_rand td_block_template_1 ">
<script type="text/javascript">
var td_screen_width = window.innerWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-9982578686703193" data-ad-slot="5759665706"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-9982578686703193" data-ad-slot="5759665706"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:200px;height:200px" data-ad-client="ca-pub-9982578686703193" data-ad-slot="5759665706"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-9982578686703193" data-ad-slot="5759665706"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 

<aside class="td_block_template_1 widget widget_text">			<div class="textwidget"><div id="BOVNews_ROS_RightRail_1"></div>
</div>
		</aside><div class="td_block_wrap td_block_9 td_block_widget td_uid_8_5f7e06dc24759_rand td-pb-border-top td_block_template_1 td-column-1 td_block_padding td_block_bot_line"  data-td-block-uid="td_uid_8_5f7e06dc24759" ><script>var block_td_uid_8_5f7e06dc24759 = new tdBlock();
block_td_uid_8_5f7e06dc24759.id = "td_uid_8_5f7e06dc24759";
block_td_uid_8_5f7e06dc24759.atts = '{"custom_title":"RECENT POSTS","custom_url":"","block_template_id":"","header_color":"#","header_text_color":"#","accent_text_color":"#","m8_tl":"","limit":"2","offset":"","el_class":"","post_ids":"","category_id":"","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","class":"td_block_widget td_uid_8_5f7e06dc24759_rand","separator":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m8f_title_font_header":"","m8f_title_font_title":"Article title","m8f_title_font_settings":"","m8f_title_font_family":"","m8f_title_font_size":"","m8f_title_font_line_height":"","m8f_title_font_style":"","m8f_title_font_weight":"","m8f_title_font_transform":"","m8f_title_font_spacing":"","m8f_title_":"","m8f_cat_font_title":"Article category tag","m8f_cat_font_settings":"","m8f_cat_font_family":"","m8f_cat_font_size":"","m8f_cat_font_line_height":"","m8f_cat_font_style":"","m8f_cat_font_weight":"","m8f_cat_font_transform":"","m8f_cat_font_spacing":"","m8f_cat_":"","m8f_meta_font_title":"Article meta info","m8f_meta_font_settings":"","m8f_meta_font_family":"","m8f_meta_font_size":"","m8f_meta_font_line_height":"","m8f_meta_font_style":"","m8f_meta_font_weight":"","m8f_meta_font_transform":"","m8f_meta_font_spacing":"","m8f_meta_":"","css":"","tdc_css":"","td_column_number":1,"color_preset":"","border_top":"","tdc_css_class":"td_uid_8_5f7e06dc24759_rand","tdc_css_class_style":"td_uid_8_5f7e06dc24759_rand_style"}';
block_td_uid_8_5f7e06dc24759.td_column_number = "1";
block_td_uid_8_5f7e06dc24759.block_type = "td_block_9";
block_td_uid_8_5f7e06dc24759.post_count = "2";
block_td_uid_8_5f7e06dc24759.found_posts = "11090";
block_td_uid_8_5f7e06dc24759.header_color = "#";
block_td_uid_8_5f7e06dc24759.ajax_pagination_infinite_stop = "";
block_td_uid_8_5f7e06dc24759.max_num_pages = "5545";
tdBlocksArray.push(block_td_uid_8_5f7e06dc24759);
</script><div class="td-block-title-wrap"><h4 class="block-title td-block-title"><span class="td-pulldown-size">RECENT POSTS</span></h4></div><div id=td_uid_8_5f7e06dc24759 class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_8 td_module_wrap">

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://bovnews.com/2020/10/07/which-one-is-a-better-investment-xperi-holding-corporation-xper-or-iamgold-corporation-iag/" rel="bookmark" title="Which One Is A Better Investment: Xperi Holding Corporation (XPER) or IAMGOLD Corporation (IAG)?">Which One Is A Better Investment: Xperi Holding Corporation (XPER) or IAMGOLD Corporation (IAG)?</a></h3>
                <div class="td-module-meta-info">
                    <a href="https://bovnews.com/category/industry/" class="td-post-category">Industry</a>                    <span class="td-post-author-name"><a href="https://bovnews.com/author/samuel-moore/">Samuel Moore</a> <span>-</span> </span>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-10-07T18:18:00+00:00" >October 7, 2020</time></span>                    <div class="td-module-comments"><a href="https://bovnews.com/2020/10/07/which-one-is-a-better-investment-xperi-holding-corporation-xper-or-iamgold-corporation-iag/#respond">0</a></div>                </div>
            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_8 td_module_wrap">

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://bovnews.com/2020/10/07/may-prove-more-resilient-than-the-market-believes-boston-properties-inc-bxp-and-the-cheesecake-factory-incorporated-cake/" rel="bookmark" title="May Prove More Resilient Than The Market Believes: Boston Properties Inc. (BXP) and The Cheesecake Factory Incorporated (CAKE)">May Prove More Resilient Than The Market Believes: Boston Properties Inc. (BXP) and The...</a></h3>
                <div class="td-module-meta-info">
                    <a href="https://bovnews.com/category/finance/" class="td-post-category">Finance</a>                    <span class="td-post-author-name"><a href="https://bovnews.com/author/peggy-goldman/">Peggy Goldman</a> <span>-</span> </span>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-10-07T18:18:00+00:00" >October 7, 2020</time></span>                    <div class="td-module-comments"><a href="https://bovnews.com/2020/10/07/may-prove-more-resilient-than-the-market-believes-boston-properties-inc-bxp-and-the-cheesecake-factory-incorporated-cake/#respond">0</a></div>                </div>
            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 --></div></div> <!-- ./block --><aside class="td_block_template_1 widget widget_text">			<div class="textwidget"><p><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br />
<!-- bov siderbar 2 --><br />
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-9982578686703193"
     data-ad-slot="3738887469"
     data-ad-format="auto"></ins><br />
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></p>
</div>
		</aside>                                </div>
                            </div>
                                    </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->

<!-- Instagram -->




	<!-- Footer -->
	<div class="td-footer-wrapper td-container-wrap td-footer-template-2 ">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
			    		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span4">
                <div class="td-footer-info"><div class="footer-logo-wrap"><a href="https://bovnews.com/"><img src="http://bovnews.com/wp-content/uploads/2019/10/BOV-logo-new-300x35.png" alt="" title=""/></a></div><div class="footer-text-wrap">BOVNews.com was originated in 2018 as a Company. Our team comprises Analysts and writers with the knowledge and expertise of Stock Markets and other sectors of Finance. 
The foremost objective is to deliver  impartial opinion  and detailed analysis on stock and markets. Our Research team is always keen to stay update on market highlights, earnings reports, mergers and acquisitions, analyst opinions, and pass on their knowledge and expertise to  our reader.<div class="footer-email-wrap">Contact us: <a href="mailto:info@bovnews.com">info@bovnews.com</a></div></div><div class="footer-social-wrap td-social-style-2"></div></div>                            </div>

            <div class="td-pb-span4">
                <div class="td_block_wrap td_block_7 td_uid_10_5f7e06dc29976_rand td-pb-border-top td_block_template_1 td-column-1 td_block_padding"  data-td-block-uid="td_uid_10_5f7e06dc29976" ><script>var block_td_uid_10_5f7e06dc29976 = new tdBlock();
block_td_uid_10_5f7e06dc29976.id = "td_uid_10_5f7e06dc29976";
block_td_uid_10_5f7e06dc29976.atts = '{"custom_title":"POPULAR POSTS","limit":3,"sort":"popular","separator":"","custom_url":"","block_template_id":"","m6_tl":"","post_ids":"","category_id":"","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","offset":"","el_class":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m6f_title_font_header":"","m6f_title_font_title":"Article title","m6f_title_font_settings":"","m6f_title_font_family":"","m6f_title_font_size":"","m6f_title_font_line_height":"","m6f_title_font_style":"","m6f_title_font_weight":"","m6f_title_font_transform":"","m6f_title_font_spacing":"","m6f_title_":"","m6f_cat_font_title":"Article category tag","m6f_cat_font_settings":"","m6f_cat_font_family":"","m6f_cat_font_size":"","m6f_cat_font_line_height":"","m6f_cat_font_style":"","m6f_cat_font_weight":"","m6f_cat_font_transform":"","m6f_cat_font_spacing":"","m6f_cat_":"","m6f_meta_font_title":"Article meta info","m6f_meta_font_settings":"","m6f_meta_font_family":"","m6f_meta_font_size":"","m6f_meta_font_line_height":"","m6f_meta_font_style":"","m6f_meta_font_weight":"","m6f_meta_font_transform":"","m6f_meta_font_spacing":"","m6f_meta_":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","css":"","tdc_css":"","td_column_number":1,"header_color":"","color_preset":"","border_top":"","class":"td_uid_10_5f7e06dc29976_rand","tdc_css_class":"td_uid_10_5f7e06dc29976_rand","tdc_css_class_style":"td_uid_10_5f7e06dc29976_rand_style"}';
block_td_uid_10_5f7e06dc29976.td_column_number = "1";
block_td_uid_10_5f7e06dc29976.block_type = "td_block_7";
block_td_uid_10_5f7e06dc29976.post_count = "3";
block_td_uid_10_5f7e06dc29976.found_posts = "10579";
block_td_uid_10_5f7e06dc29976.header_color = "";
block_td_uid_10_5f7e06dc29976.ajax_pagination_infinite_stop = "";
block_td_uid_10_5f7e06dc29976.max_num_pages = "3527";
tdBlocksArray.push(block_td_uid_10_5f7e06dc29976);
</script><div class="td-block-title-wrap"><h4 class="block-title td-block-title"><span class="td-pulldown-size">POPULAR POSTS</span></h4></div><div id=td_uid_10_5f7e06dc29976 class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://bovnews.com/2020/09/17/long-term-bull-case-remains-untouched-wesco-international-inc-wcc-and-american-axle-manufacturing-holdings-inc-axl/" rel="bookmark" class="td-image-wrap" title="Long-Term Bull Case Remains Untouched: WESCO International Inc. (WCC) and American Axle &#038; Manufacturing Holdings Inc. (AXL)"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII="alt="" title="Long-Term Bull Case Remains Untouched: WESCO International Inc. (WCC) and American Axle &#038; Manufacturing Holdings Inc. (AXL)" data-type="image_tag" data-img-url="https://bovnews.com/wp-content/uploads/2019/10/3-1-100x70.jpg"  width="100" height="70" /></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://bovnews.com/2020/09/17/long-term-bull-case-remains-untouched-wesco-international-inc-wcc-and-american-axle-manufacturing-holdings-inc-axl/" rel="bookmark" title="Long-Term Bull Case Remains Untouched: WESCO International Inc. (WCC) and American Axle &#038; Manufacturing Holdings Inc. (AXL)">Long-Term Bull Case Remains Untouched: WESCO International Inc. (WCC) and American...</a></h3>            <div class="td-module-meta-info">
                <a href="https://bovnews.com/category/finance/" class="td-post-category">Finance</a>                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-09-17T15:18:00+00:00" >September 17, 2020</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://bovnews.com/2020/09/28/when-the-smoke-clears-youll-be-happy-to-own-owl-rock-capital-corporation-orcc-cardiff-oncology-inc-crdf/" rel="bookmark" class="td-image-wrap" title="When The Smoke Clears, You&#8217;ll Be Happy To Own: Owl Rock Capital Corporation (ORCC), Cardiff Oncology Inc. (CRDF)"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII="alt="" title="When The Smoke Clears, You&#8217;ll Be Happy To Own: Owl Rock Capital Corporation (ORCC), Cardiff Oncology Inc. (CRDF)" data-type="image_tag" data-img-url="https://bovnews.com/wp-content/uploads/2019/10/3-1-100x70.jpg"  width="100" height="70" /></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://bovnews.com/2020/09/28/when-the-smoke-clears-youll-be-happy-to-own-owl-rock-capital-corporation-orcc-cardiff-oncology-inc-crdf/" rel="bookmark" title="When The Smoke Clears, You&#8217;ll Be Happy To Own: Owl Rock Capital Corporation (ORCC), Cardiff Oncology Inc. (CRDF)">When The Smoke Clears, You&#8217;ll Be Happy To Own: Owl Rock...</a></h3>            <div class="td-module-meta-info">
                <a href="https://bovnews.com/category/companies/" class="td-post-category">Companies</a>                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-09-28T17:27:00+00:00" >September 28, 2020</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://bovnews.com/2020/09/04/estimates-could-be-right-town-sports-international-holdings-inc-club-22nd-century-group-inc-xxii/" rel="bookmark" class="td-image-wrap" title="Estimates could be Right: Town Sports International Holdings Inc. (CLUB), 22nd Century Group Inc. (XXII)"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII="alt="" title="Estimates could be Right: Town Sports International Holdings Inc. (CLUB), 22nd Century Group Inc. (XXII)" data-type="image_tag" data-img-url="https://bovnews.com/wp-content/uploads/2019/10/11-100x70.jpg"  width="100" height="70" /></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://bovnews.com/2020/09/04/estimates-could-be-right-town-sports-international-holdings-inc-club-22nd-century-group-inc-xxii/" rel="bookmark" title="Estimates could be Right: Town Sports International Holdings Inc. (CLUB), 22nd Century Group Inc. (XXII)">Estimates could be Right: Town Sports International Holdings Inc. (CLUB), 22nd...</a></h3>            <div class="td-module-meta-info">
                <a href="https://bovnews.com/category/industry/" class="td-post-category">Industry</a>                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-09-04T16:45:00+00:00" >September 4, 2020</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 --></div></div> <!-- ./block -->                            </div>

            <div class="td-pb-span4">
                <div class="td_block_wrap td_block_popular_categories td_uid_11_5f7e06dc4db28_rand widget widget_categories td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_11_5f7e06dc4db28" ><div class="td-block-title-wrap"><h4 class="block-title td-block-title"><span class="td-pulldown-size">POPULAR CATEGORY</span></h4></div><ul class="td-pb-padding-side"><li><a href="https://bovnews.com/category/finance/"><span class="td-cat-name">Finance</span><span class="td-cat-no">2873</span></a></li><li><a href="https://bovnews.com/category/companies/"><span class="td-cat-name">Companies</span><span class="td-cat-no">2779</span></a></li><li><a href="https://bovnews.com/category/industry/"><span class="td-cat-name">Industry</span><span class="td-cat-no">2768</span></a></li><li><a href="https://bovnews.com/category/market/"><span class="td-cat-name">Market</span><span class="td-cat-no">2670</span></a></li></ul></div> <!-- ./block -->                            </div>
        </div>
    </div>
</div>

	<!-- Sub Footer -->
	    <div class="td-sub-footer-container td-container-wrap ">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span td-sub-footer-menu">
                    <div class="menu-td-demo-footer-menu-container"><ul id="menu-td-demo-footer-menu" class="td-subfooter-menu"><li id="menu-item-114" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-114"><a href="https://bovnews.com/">Home</a></li>
<li id="menu-item-115" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-115"><a href="https://bovnews.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-116" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-116"><a href="https://bovnews.com/our-team/">Our Team</a></li>
<li id="menu-item-117" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-117"><a href="https://bovnews.com/our-company/">Our Company</a></li>
<li id="menu-item-118" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-118"><a href="https://bovnews.com/disclaimer/">Disclaimer</a></li>
<li id="menu-item-119" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-119"><a href="https://bovnews.com/contacts/">Contacts</a></li>
</ul></div>                </div>

                <div class="td-pb-span td-sub-footer-copy">
                    &copy; All Rights Reserved! BOVNews.com                 </div>
            </div>
        </div>
    </div>


</div><!--close td-outer-wrap-->



    <!--

        Theme: Newspaper by tagDiv.com 2017
        Version: 9.2.2 (rara)
        Deploy mode: deploy
        
        uid: 5f7e06dc541ec
    -->

    <script type='text/javascript'>
/* <![CDATA[ */
var adsforwp_obj = {"ajax_url":"https:\/\/bovnews.com\/wp-admin\/admin-ajax.php","adsforwp_front_nonce":"29896dbeaf"};
/* ]]> */
</script>
<script type='text/javascript' src='https://bovnews.com/wp-content/plugins/ads-for-wp/public/assets/js/ads-front.min.js?ver=1.9.16.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var adsforwp_browser_obj = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://bovnews.com/wp-content/plugins/ads-for-wp/public/assets/js/ads-frontend.min.js?ver=1.9.16.1'></script>
<script type='text/javascript' src='https://bovnews.com/wp-content/themes/Newspaper/js/tagdiv_theme.min.js?ver=9.2.2'></script>
<script type='text/javascript' src='https://bovnews.com/wp-includes/js/comment-reply.min.js?ver=5.3.4'></script>
<script type='text/javascript' src='https://bovnews.com/wp-includes/js/wp-embed.min.js?ver=5.3.4'></script>

<!-- JS generated by theme -->

<script>
    

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'https://bovnews.com/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'https://bovnews.com/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>



			<div id="tdw-css-writer" style="display: none" class="tdw-drag-dialog tdc-window-sidebar">
				<header>

				
					<a title="Editor" class="tdw-tab tdc-tab-active" href="#" data-tab-content="tdw-tab-editor">Edit with Live CSS</a>
					<div class="tdw-less-info" title="This will be red when errors are detected in your CSS and LESS"></div>
				
				</header>
				<div class="tdw-content">

					
					<div class="tdw-tabs-content tdw-tab-editor tdc-tab-content-active">


						<script>

							(function(jQuery, undefined) {

								jQuery(window).ready(function() {

									if ( 'undefined' !== typeof tdcAdminIFrameUI ) {
										var $liveIframe  = tdcAdminIFrameUI.getLiveIframe();

										if ( $liveIframe.length ) {
											$liveIframe.load(function() {
												$liveIframe.contents().find( 'body').append( '<textarea class="tdw-css-writer-editor" style="display: none"></textarea>' );
											});
										}
									}

								});

							})(jQuery);

						</script>


						<textarea class="tdw-css-writer-editor td_live_css_uid_1_5f7e06dc54318"></textarea>
						<div id="td_live_css_uid_1_5f7e06dc54318" class="td-code-editor"></div>


						<script>
							jQuery(window).load(function (){

								if ( 'undefined' !== typeof tdLiveCssInject ) {

									tdLiveCssInject.init();


									var editor_textarea = jQuery('.td_live_css_uid_1_5f7e06dc54318');
									var languageTools = ace.require("ace/ext/language_tools");
									var tdcCompleter = {
										getCompletions: function (editor, session, pos, prefix, callback) {
											if (prefix.length === 0) {
												callback(null, []);
												return
											}

											if ('undefined' !== typeof tdcAdminIFrameUI) {

												var data = {
													error: undefined,
													getShortcode: ''
												};

												tdcIFrameData.getShortcodeFromData(data);

												if (!_.isUndefined(data.error)) {
													tdcDebug.log(data.error);
												}

												if (!_.isUndefined(data.getShortcode)) {

													var regex = /el_class=\"([A-Za-z0-9_-]*\s*)+\"/g,
														results = data.getShortcode.match(regex);

													var elClasses = {};

													for (var i = 0; i < results.length; i++) {
														var currentClasses = results[i]
															.replace('el_class="', '')
															.replace('"', '')
															.split(' ');

														for (var j = 0; j < currentClasses.length; j++) {
															if (_.isUndefined(elClasses[currentClasses[j]])) {
																elClasses[currentClasses[j]] = '';
															}
														}
													}

													var arrElClasses = [];

													for (var prop in elClasses) {
														arrElClasses.push(prop);
													}

													callback(null, arrElClasses.map(function (item) {
														return {
															name: item,
															value: item,
															meta: 'in_page'
														}
													}));
												}
											}
										}
									};
									languageTools.addCompleter(tdcCompleter);

									window.editor = ace.edit("td_live_css_uid_1_5f7e06dc54318");
                                    window.editor.$blockScrolling = Infinity;

                                    // 'change' handler is written as function because it's called by tdc_on_add_css_live_components (of wp_footer hook)
									// We did it to reattach the existing compiled css to the new content received from server.
									window.editorChangeHandler = function () {
										//tdwState.lessWasEdited = true;

										window.onbeforeunload = function () {
											if (tdwState.lessWasEdited) {
												return "You have attempted to leave this page. Are you sure?";
											}
											return false;
										};

										var editorValue = editor.getSession().getValue();

										editor_textarea.val(editorValue);

										if ('undefined' !== typeof tdcAdminIFrameUI) {
											tdcAdminIFrameUI.getLiveIframe().contents().find('.tdw-css-writer-editor:first').val(editorValue);

											// Mark the content as modified
											// This is important for showing info when composer closes
                                            tdcMain.setContentModified();
										}

										tdLiveCssInject.less();
									};

									editor.getSession().setValue(editor_textarea.val());
									editor.getSession().on('change', editorChangeHandler);

									editor.setTheme("ace/theme/textmate");
									editor.setShowPrintMargin(false);
									editor.getSession().setMode("ace/mode/less");
                                    editor.getSession().setUseWrapMode(true);
									editor.setOptions({
										enableBasicAutocompletion: true,
										enableSnippets: true,
										enableLiveAutocompletion: false
									});

								}

							});
						</script>

					</div>
				</div>

				<footer>

					
						<a href="#" class="tdw-save-css">Save</a>
						<div class="tdw-more-info-text">Write CSS OR LESS and hit save. CTRL + SPACE for auto-complete.</div>

					
					<div class="tdw-resize"></div>
				</footer>
			</div>
			
</body>
</html>